Are there plan to support openssl1.1.x within Confd?

In current, it only run confd within openssl version < 1.1.0

Partly discussed here Compile fails on ubuntu 18.04 .

Does that mean no plan to support openssl 1.1.x within confd in future?
While from erlang’s 20+ version, it did support openssl 1.1.0 now.

Anybody met similar requirement for openssl upgrade?

No. It means that at some time in the future the Erlang/OTP runtime shipped with ConfD will be upgraded to version 20 (or some later version). At that point, ConfD will support OpenSSL 1.1.x (or later).

supporting libssl-dev 1.0 just for one component is going to make our development environment harder to manage.

On Ubuntu 18.04 for example you don’t need the libssl-dev 1.0 package. Only the libssl1.0.0 package in addition to the libssl-dev (1.1) package.