ConfD User Community

<file> with wd= not working saying access denied for /var/log


#1

Hi All!

We upgraded to confined version 6.4.3 earlier we were using 5.x. We have given the path to show the list of files in our .cli files as in 5.x it was working and showing files but in 6.4.3 we see the files are not listed and if we still try entering a name it says access denied. Please let us know how can we debug the same…

rgds
Balaji Kamal Kannadassan


#2

Haven’t got an update on the same ?. Please let us know if you need any further input for the same ?.

monitor log to balaji
---------------------^
syntax error: access denied

Only current directory works i.e

"<file wd=<directory from where confd was started>/>" works..

One more strange observation, if I give one directory above the cwd which I give in confd_cli

# monitor log to 
Possible completions:
  <file>  ../

its showing option as one directory back…

rgds
Balaji Kamal Kannadassan


#3

What I could narrow down is in confd_cli whichever I directory I am giving

i.e if I give --cwd="/root/balaji"

I can use any directory after this in file option wd but if I give “/var/log” it doesn’t work…
Btw this is the behaviour with 6.4.3 in 5.0 it was working.

rgds
Balaji Kamal Kannadassan