ConfD User Community

Hidden tailf extension is not working in the annotated file for an augmented field

Hi,

i have a yang file which has augmented openconfig interfaces.

augment "/oc-if:interfaces/oc-if:interface/oc-eth:ethernet/oc-eth:config" {
  leaf flow-control {
        type on_off_enum;
  }
}

I am trying to hide this paramter in an annotation file.

tailf:annotate "/oc-if:interfaces/oc-if:interface/oc-eth:ethernet/oc-eth:config/eth-ext:flow-control" {
      tailf:hidden full;
}

But i still see this parameter appearing in confd cli. Any idea?

I found the reason what went wrong with this. I missed including augmented yang file during compilation.i just included openconfig interface file. After including augmented yang file it worked fine.

1 Like