I'd like to use ssh instead of using netconf-console with xml

Until now, I have run RPC using netconf-console as shown below.
“# netconf-console -s all ./rpcaco.xml -u user -p passwd”
I would like to do the same thing using ssh.
When I entered “# ssh -s user@localhost netconf”, capibilities were responded.
But, I don’t know how to do for run RPC.
Please, let me know about it.

You would have to manually enter the XML RPCs as defined the NETCONF RFC. This is something which people don’t normally do.

You may also want to explore use of the interactive mode of netconf-console with the -i or --interactive option which allows you to manually enter one or more RPC requests.

An example usage of netconf-console’s interactive mode is shown in this posting at Candidate datastore.

I have understood the usage of the netconf-console with interactive option that waitai taught to me.
thanks your kindness.

I have another question when using ssh.
when I ran “ssh -s user@localhost netconf”, I could see the capabilities from confd.
after that, and I tried rpc statement but shell was broken.

following statement is error message.

.!-- Error: bad element: /rpc (closing session) –

Is it impossible to run rpc statement in ssh directly ?