Can't enable https in confd http server

Can’t get https working with confd. http works fine and netstat reports confd is listening on both http and https sockets, but you can’t get a response out of confd, always get “Site can’t be reached” from browser and wget gives:

wget --user=Administrator --ask-password
Password for user ‘Administrator’:
–2016-05-06 09:24:18--
Connecting to… connected.
Unable to establish SSL connection.

It’s like ssl is not enabled in my build of confd.

This is an excerpt from my confd.config file:


Have you tried without the empty <keyFile>/<certFile> elements in confd.conf?

With empty elements as in your config file the latest version of ConfD refuse to start and complains about bad configuration. Apparently the version of ConfD you use accepts your config, maybe older ConfD versions does even though it’s wrong - I haven’t had time to check - and look for the certificate key in the wrong place.

Hi again,
I tried using ConfD 5.3 and the behavior is the same as with ConfD 6.1.2, empty <keyFile>/<certFile> tags cause ConfD to fail during startup. Without the tags ConfD I can connect using both http and https.

Which ConfD version do you use?