ConfD User Community

CBD not picking init values

I am using confd-4.0.3. When confd boots up i am trying to init it with some default xmls.
a.xml, b.xml, c.xml. All these XML files are placed in the cdb directory and path are updated in the confd.conf file.

Once the system bootups the default values are not updated in CDB.

More over when checked the devel.log, it was showing
init files found in cdd directory:

but not showing the file names ? Any idea what would have gone wrong ?

Can you try this with confd-6.1? You can download ConfD Basic at http://www.tail-f.com/management-agent/.

Do you use aaa_init.xml in your project? Did it get loaded into CDB properly? Have you tried this with one of ConfD’s examples that came with the distribution and add an additional init xml files to the project in the default cdb directory?

Is there any specific issue with confd-4.0.3 ? May i know why you suggest confd-6.1, just because its latest version ?
The aaa_init.xml which is in the cdb directory is also not getting read.

The ConfD User Community Forum provides a supplement for the standard Post-Sales Request Tracker (RT) system. Focus here is the latest versions of ConfD and ConfD Basic. RT is still your primary channel for ConfD support from Tail-f, which may include older versions of ConfD.

Do you have *.cdb files present in your CDB directory?

Note that at startup, only when CDB is empty, i.e. no database files are found in the CDB directory, CDB will try to initialize the database from all instantiated XML documents found in the CDB directory. This is the mechanism we use to have an empty database initialized to some default setup.
See ConfD UG Chapter “Loading initial data into CDB”

If you want to load an XML file with a populated CDB you can for example use the confd_load tool or the load command in the CLI.

Thanks… I have deleted all the cdb files in the cdb directory… All it will have is the XML files which are supposed to get initialized. When the system gets boot A.cdb 0.cdb are created. But they don’t have any init values which are there in the XML.

As you mentioned I tried confd_load, both merge and replace options are replacing my values to init, and I am not able to retain the modified values once the system gets reboot… Can you suggest something to debug further.

Strange behaviour indeed. If you can show us your YANG and XML files we can take a look and try to reproduce