ConfD User Community

Compiling confd with ciscossl

I am trying to install confd using ciscossl. I was able to compile and as per the instructions in the confd-7.2.2.libconfd.tar.gz. After installing it I see pointing to AlmaLinux openssl but not to ciscossl.

[root@nfvis cisco]# ldd /opt/confd/lib/confd/lib/core/crypto/priv/lib/ (0x00007ffce5ef9000) => /lib64/ (0x00007f2704e25000)

Need pointing to ciscossl as below. => /opt/cisco/csm-toolkit/tools/ciscossl/lib/ (0x00007f92a0d59000)

Try setting the LD_LIBRARY_PATH so that ConfD uses the intended - e.g.:

$ export LD_LIBRARY_PATH=/opt/cisco/csm-toolkit/tools/ciscossl/lib:$LD_LIBRARY_PATH

If that does not do it for you, when compiling, did you do something like the below?:

$ export USE_SSL_DIR=/opt/cisco/csm-toolkit/tools/ciscossl
$ tar xfz confd-7.2.2.libconfd.tar.gz
$ cd confd-7.2.2/libconfd
$ make crypto
$ make CONFD_DIR=/opt/confd install_crypto

Setting LD_LIBRARY_PATH is breaking modules that require AlmaLinux Modules.(Some python scripts need it load AlmaLinux libraries)
Tried the above steps of make and install_crypto using USE_SSL_DIR=/opt/cisco/csm-toolkit/tools/ciscossl. Still the generated is pointing to AlamLinux openssl.(tried using all files, libconfd.a(static library), and Still, : => /lib64/

See, for example, section “Installing and Using a Shared Library” here: Shared Libraries