Confd 6.4 and RESTCONF

Using RESTCONF with Confd 6.4.

When issuing GET,

curl -v -k -H "Accept: application/yang-data+json" -u admin:admin
root@RR1-NEW:/var/arcos/confd# curl -v -k -H "Accept: application/yang-data+json" -u admin:admin -X GET

* Hostname was NOT found in DNS cache
*   Trying
* Connected to ( port 8008 (#0)
* Server auth using Basic with user 'admin'
> GET /restconf/data/bgp HTTP/1.1
> Authorization: Basic YWRtaW46YWRtaW4=
> User-Agent: curl/7.38.0
> Host:
> Accept: application/yang-data+json


< HTTP/1.1 200 OK

* Server  is not blacklisted
< Server: 

< Date: Tue, 15 Aug 2017 02:25:04 GMT

< Last-Modified: Tue, 15 Aug 2017 02:12:12 GMT

< Cache-Control: private, no-cache, must-revalidate, proxy-revalidate

< Etag: 1502-576497-785453

< Content-Type: application/yang-data+json

< Transfer-Encoding: chunked

< Pragma: no-cache



  "openconfig-bgp:bgp": {

    "global": {

      "config": {

        "as": 222,

        "router-id": ""


<<<hangs here

But when using DEPTH option, it works. What am I missing?

curl -v -k -H "Accept: application/yang-data+json" -u admin:admin


I tried this with ConfD 6.4.2 and it works fine both with and without the depth parameter. Try upgrading and see if that helps.

Hi Johansson,
Thanks for the response

Is there a known bug in 6.4 that prevents this from working?
Any chance you have tried this with 6.4?


There’s been quite a few RESTCONF bug fixes since ConfD 6.4 (10+). Nothing in particular sticks out but the list include only externally reported tickets and it’s certainly possible, likely even, that engineering have made other improvements as well.

I haven’t tried with ConfD 6.4 myself, If you need more information or a patch on ConfD 6.4, it’s best if you file a ticket with ConfD support.

I tried with ConfD 6.4, with fresh install on Ubuntu 16.04 and it works fine with the same curl command you used.

I’m not sure what happens in your case. It could be due to your configuration data or other YANG models you have installed. In any case, as far as I can tell you’re not doing anything wrong and it’s probably best if you contact support.

Could you attach the curl version and output of your test session (with curl -v option) to the thread, pls? Not sure sure if there is a curl version mis-match or some curl option that could be causing this.

Saw this on 2 separate CONFD installations for different nodes in the tree.


Hi Jonas,
Looks this is getting stuck because CONFD is waiting for a callpoint to return. Can be seen in the devel.log. this issue can be closed.

thanks for all your help,