ConfD User Community

Confd-6.5.2.linux.x86_64.installer.bin

Hi all,

If i install confD 6.5.2 using the installer:

./confd-6.5.2.linux.x86_64.installer.bin /tmp/confd-6.5.2_1

Following directory gets created:
confd-6.5.2_1:
total 384
drwxr-xr-x 3 docker docker 4096 Dec 1 2017 var
drwxr-xr-x 3 docker docker 4096 Dec 1 2017 src
drwxr-xr-x 3 docker docker 4096 Dec 1 2017 etc
-rw-r–r-- 1 docker docker 216 Dec 1 2017 VERSION
-rw-r–r-- 1 docker docker 11577 Dec 1 2017 README
-rw-r–r-- 1 docker docker 76279 Dec 1 2017 LICENSE
-rw-r–r-- 1 docker docker 648 Dec 1 2017 KNOWN_ISSUES
drwxr-xr-x 3 docker docker 4096 Dec 1 2017 java
drwxr-xr-x 2 docker docker 4096 Dec 1 2017 include
drwxr-xr-x 3 docker docker 4096 Dec 1 2017 erlang
-rw-r–r-- 1 docker docker 252208 Dec 1 2017 CHANGES
drwxr-xr-x 2 docker docker 4096 Dec 1 2017 bin
drwxr-xr-x 5 docker docker 4096 Dec 1 2017 lib
-rw-rw-r-- 1 docker docker 535 Sep 15 17:21 confdrc.tcsh
-rw-rw-r-- 1 docker docker 569 Sep 15 17:21 confdrc

docker@docker-171:/tmp$ ls -ltr confd-6.5.2_1/java/jar
total 6588
lrwxrwxrwx 1 docker docker 16 Dec 1 2017 log4j.jar -> log4j-1.2.16.jar
-rw-r–r-- 1 docker docker 481534 Dec 1 2017 log4j-1.2.16.jar
lrwxrwxrwx 1 docker docker 22 Dec 1 2017 conf-api-src.jar -> conf-api-src-6.5.2.jar
-rw-r–r-- 1 docker docker 5268674 Dec 1 2017 conf-api-src-6.5.2.jar
lrwxrwxrwx 1 docker docker 18 Dec 1 2017 conf-api.jar -> conf-api-6.5.2.jar
-rw-r–r-- 1 docker docker 988258 Dec 1 2017 conf-api-6.5.2.jar
docker@docker-171:/tmp$

But if install the ConfD 7.3, i don’t see the “java” folder:
Question#1) Any idea why the “java” folder is not getting created as part of the ConfD 7.3 installer ?
Question#2) Where can i find the corresponding conf-api-src-7.3.jar for ConfD 7.3 ?

./confd-basic-7.3.linux.x86_64.installer.bin /tmp/confd-7.3_1

Following directory gets created:
confd-7.3_1:
total 588
drwxr-xr-x 3 docker docker 4096 Dec 17 2019 var
drwxr-xr-x 3 docker docker 4096 Dec 17 2019 src
drwxr-xr-x 3 docker docker 4096 Dec 17 2019 etc
-rw-r–r-- 1 docker docker 11470 Dec 17 2019 README
-rw-r–r-- 1 docker docker 76280 Dec 17 2019 LICENSE
-rw-r–r-- 1 docker docker 982 Dec 17 2019 KNOWN_ISSUES
-rw-r–r-- 1 docker docker 466629 Dec 17 2019 CHANGES
-rw-r–r-- 1 docker docker 271 Dec 17 2019 VERSION
drwxr-xr-x 2 docker docker 4096 Dec 17 2019 include
drwxr-xr-x 4 docker docker 4096 Dec 17 2019 erlang
drwxr-xr-x 2 docker docker 4096 Dec 17 2019 bin
drwxr-xr-x 5 docker docker 4096 Dec 17 2019 lib
-rw-rw-r-- 1 docker docker 537 Sep 15 17:22 confdrc.tcsh
-rw-rw-r-- 1 docker docker 571 Sep 15 17:22 confdrc

Thanks for the help,

BR
Kanthi

You are using confd-basic-7.3. Java API is not available with the basic version, you need to have the full version for that.

Thanks mvf.

Please share the link from where can we download the full version of confd 7.3 ?

BR,
Kanthi

The full version is not free; but since you have full version of 6.5.2, you should be able to get hold of full 7.3 using the same channel you used for obtaining 6.5.2.