Confd cli : No listening socket on port 2024

I enabled confd cli for IQC in same way as we have enabled confd cli for IQNOS by make cli enabled as true in confd.conf file and then started the confd and found that there is no listening socket on port 2024.

Please suggest why I am not able to listen on 2024 port.

It’s not enough to set /confdCnfig/cli/enabled to true, in order to allow ssh connections on port 2024 you must also set /confdCnfig/cli/ssh/enabled to true.

By default, confd_cli connects to ConfD using the IPC port (4565) not 2024.