ConfD User Community

Create-subscription for integration with OpenDaylight

Hi,

We use ConfD 7.3 basic for our device.
Our parter uses OpenDaylight to communicate with our device.

After NETCONF session established, it can’t invoke create-subscription from ODL on ConfD.

In the study so far, we observe ODL stucks in these steps:

  1. Check capability for urn:ietf:params:xml:ns:netconf:notification:1.0?module=notifi
    cations&revision=2008-07-14
  2. Get schema for the module with namespace urn:ietf:params:xml:ns:netconf:notification:1.0.

Refer to [https://info.tail-f.com/hubfs/Whitepapers/App%20Note_Confd%20integration%20with%20OpenDaylight.pdf](Confd integration with OpenDaylight), step 1 is resolved, i.e., the capability is added successfully.

But the schema of module with namespace urn:ietf:params:xml:ns:netconf:notification:1.0 is still not available from ConfD for step 2.

Do we miss something or any other method to provide the schema from ConfD ?

We have tried to add a new fxs file with namespace urn:ietf:params:xml:ns:netconf:notification:1.0, but it fails since the namespace is implemented.

Thanks.

Hi,

I am not sure how you would be able to get some (old) 2008-07-14 revision from ConfD.
ConfD support the 2012-02-06 revision (latest) of ietf-netconf-notifications (RFC 6470):

$ netconf-console --get -x /yang-library | grep -A3 -B1 "name>ietf-netconf-notifications"
        <module>
          <name>ietf-netconf-notifications</name>
          <revision>2012-02-06</revision>
          <namespace>urn:ietf:params:xml:ns:yang:ietf-netconf-notifications</namespace>
        </module>
$ netconf-console --get-schema=ietf-netconf-notifications
module ietf-netconf-notifications {

  namespace
    "urn:ietf:params:xml:ns:yang:ietf-netconf-notifications";

  prefix ncn;

  import ietf-inet-types { prefix inet; }
  import ietf-netconf { prefix nc; }

...

Hi,

Sorry, my question is not described clearly !
The issue is about unavailability of invoking create-subscription from ODL towards ConfD.

The schema with 2008-07-14 revision is defined in RFC5277 and is supported by ConfD 7.3. (according to UG.)
It defines the RPC create-subscription, not notification events defined by RFC 6470.

For ODL, it gets capabilities and tries to get schema of YANG modules from NETCONF server to create mount point of RPCs.

We don’t know is it possible and how to set up ConfD for providing the schema of create-subscription via get-schema.

By checking the release package of ConfD 7.3, we find the file netconf_notification.fxs (under $CONFD/lib/confd/lib/netconf/netconf/priv) seems to define the RPC:

================= netconf_notification.fxs =================
Confdc version: “7.3_0” (current Confdc version = “7.3_0”)
uri: urn:ietf:params:xml:ns:netconf:notification:1.0
id: urn:ietf:params:xml:ns:netconf:notification:1.0
prefix: “ncn”
flags: 16
type: exs
mount-id: []
exported agents: []
dependencies: []
embedded YANG source: not present
checksum: 3ca5f5f18904d1730890c010d2ff6285
cdb checksum:

But it doesn’t include the schema content.

We have tried to put the YANG module with the same module name and namespace in loadPath, but it still fails.

Thanks.

The referenced app note has been obsoleted. Step 2 no longer works. A bug has been filed with ODL on this integration issue a while back. You can refer to https://jira.opendaylight.org/browse/NETCONF-338 for more information. It looks like it has been marked as resolved.

Hi waitai,

Thanks for your information.
I’ll share this with our partner.

Thanks !