ConfD User Community

Empty server field in replies via REST


#1

When querying confd via its REST API, I see that in the replies the server field of the HTTP header is empty.

In the documentation, in Section 21.2.2 (Accessing the REST API), I see the field is filled in with the version of Confd:
Server: ConfD/5.3.0

Is there a way to do the same? Perhaps a variable to set in confd.conf?


#2

Are you using ConfD Basic?


#3

No, I have the premium version.


#4

I think you would need to choose the value you want to set. It’s not automatically set.
You can do that in confd.conf.

Example:

  <rest>
    <enabled>true</enabled>
<!-- /confdConfig/rest/customHeaders/header -->
    <customHeaders>
        <header>
                <name>Server</name>
                <value>ConfD</value>
        </header>
    </customHeaders>
  </rest>