I use odl to connect confd according the document of “CONFD INTEGRATION WITH OPENDAYLIGHT”. How to solve the problem as below:



Does your loadpath point to $(CONFD_DIR)/etc/confd ?

From the document:

We should also make sure to have both YANG source files and their compiled version in the loadpath of ConfD. The loadpath is configurable in confd.conf or can be added as an option to the confdc compiler (“man confdc” for more details).

I realised there is a typo in the text I quoted. It should say “confd” where it says “confdc” or “confdc compiler”. The loadpath is given to ConfD through confd.conf and/or the --addloadpath flag.

From the $CONFD_DIR/man/man1/confd.1 man page:

       --addloadpath Dir
           Add Dir to the set of directories ConfD uses to load fxs, clispec and, optionally, bin files.