ConfD User Community

Getting error Failed to change working directory /var/confd/homes/admin

Installed Confd 6.0 .
Have the followingin start-confd.sh.to integrate with CTCM

CONFD_DIR="${HOME}/confd6.0"
WORKSPACE="${HOME}/qvpcTest"

source ${CONFD_DIR}/confdrc
export PATH=$PATH:${WORKSPACE}/bin
${CONFD_DIR}/bin/confd --foreground --verbose $@

See the following error in the output of start-confd.sh while using CTCM to spawn vm

30-Jul-2015::15:04:10.957 nso-172-105 confd[5945]: confd osCommand error: /home/luser/confd6.0/lib/confd/lib/core/confd/priv/cmdwrapper -I 127.0.0.1 -p 4565 -i 0 -m 6 -c “/var/confd/homes/admin” -U 10 -e qvpc-bootstrap J21vZGUnICdkaScgJ2FjdGlvbicgJ2xpc3QnICB3b3Jrc3BhY2UgJy9ob21lL2x1c2VyL3F2cGNUZXN0Jw==: error: (non-fatal) failed to change working directory /var/confd/homes/admin

I assume you are invoking some sort of action or user-defined RPC as the ‘admin’ user and in cmdwrapper it is being passed the home directory of the admin user as the current working directory. The home directory for the admin user is in aaa_init.xml set to /var/confd/homes/admin. You can either change the home directory to be something that makes sense on your platform, or create the directory /var/confd/homes/admin. I don’t know what qvpc-bootstrap is doing, but if it trying to open a file for example, this could trigger the error. On most systems where I run ConfD, there is no directory /var/confd/homes/admin, and I never see this error.

Greg

I have tried changing the directory to where all the files for confd like examples and var folder and others are present. I have a custom RPC which might call Java, C or bash file. I changed the homedir in aaa_init.xml