Getting error while upgrading ConfD 6.5.2 to ConfD 6.7.3


While upgrading ConfD 6.5.2 to ConfD 6.7.3 getting below error -
"ConfD requires a version of the library that could not
be found on your system: => not found

The missing library must be installed using exactly the name shown above
to succesfully run ConfD. If you have the correct library version
installed using another name, this problem may be solved by creating a
symbolic link to the installed library with the name ConfD requires."

Could anyone help me on this?


Look strange as both version should need

Not sure if this is the same issue, but you may check:

No, it is not related to SSH host keys… The reason should be one of:

1) The instructions in the “Using a different version of OpenSSL” section of the User Guide were used for the ConfD-6.5.2 installation, but haven’t been used for 6.7.3.

2) The OS has also been upgraded and

a) the old OS version actually had a library, while the new version does not, or

b) the problem was “fixed” by creating a symlink (valid for OpenSSL versions 1.0.x) in the old OS, and this has not been done in the new OS.

Right, I meant the second post in the referred thread (which is related to a) )

Ah, sorry for not following the link - yes, that could very well be the case, OpenSSL 1.1 seems to be rapidly becoming the norm in current OS distributions. And to actually have ConfD use the libcrypto library from OpenSSL 1.1, you need ConfD 7.1 or later, since there are non-backwards-compatible changes in the interface. ConfD 7.1 is still built for the 1.0 interface, but you can use the procedure in the User Guide to have it use 1.1.


I tried the above process which is available on shared link.
But still its not working … Is ConfD 6.7.3 is stable version?


Hi Rahul,

What version and what name does your libcrypto library have?
On my Ubuntu Linux 17.04:

$ sudo locate
$ which ssh
$ ldd /usr/bin/ssh
... => /lib/x86_64-linux-gnu/ (0x00007f8a3f5d4000)

Hi Cohult,

Same version of libcrypto we are using -


Can you run the commands I ran above and provide the output just as I did?

vm-n5s1:~# find / -name “”
find: ‘/proc/28257’: No such file or directory
vm-n5s1:~# which ssh
vm-n5s1:~# ldd /usr/bin/ssh (0x00007ffcc20ca000) => /usr/lib64/ (0x00007fc70bd1e000) => /lib64/ (0x00007fc70bb1a000) => /lib64/ (0x00007fc70b905000) => /lib64/ (0x00007fc70b6ee000) => /lib64/ (0x00007fc70b34a000)
/lib64/ (0x00007fc70c167000)

Please, can you also try

ldd $CONFD_DIR/lib/

I have output: (0x00007fff4f34e000) => /lib/x86_64-linux-gnu/ (0x00007f50c5d9e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f50c5b59000) => /lib/x86_64-linux-gnu/ (0x00007f50c596e000)
	/lib64/ (0x00007f50c6088000) => /lib/x86_64-linux-gnu/ (0x00007f50c5968000)

Agree with @mnovak. You seem to have an issue with paths.