ConfD User Community

How to change SSH port in CONFD


#1

Every time I try to install confD i got a problem "Cannot bind to NETCONF socket 0.0.0.0:2022 : address already in use
Daemon died status=20
"
cannot bind because ncs also uses port 2022 and this port is configured as ssh port in configuration file confd/confd.conf

is there a way to change the port ?


#2

No problem, just change the ConfD NETCONF port in your confd.conf (ConfD configuration file):

$ cat confd.conf
...
 <netconf>
    <enabled>true</enabled>
    <transport>
      <ssh>
        <enabled>true</enabled>
        <ip>0.0.0.0</ip>
        <port>2022</port>
      </ssh>
...

Regarding NSO integrations I can recommend this blog post and appnote:
http://www.tail-f.com/know-confd-can-integrate-cisco-nso/