ConfD User Community

How to enable confd cli for IQC


#1

Hi All,

I want to enable confd cli for IQC in same way as we have enabled confd cli for IQNOS.
I tried enabling in confd.conf file by making cli as true but it did’nt worked.

Please suggest.


#2

ConfD CLI is enabled by default, but I assume you are explicitly enabling it in your confd.conf file. Did you change the port used by SSH for the CLI from its default, which is 2024?

Once you have started ConfD, you can check that there is a listening socket on that port, so for example you would enter ‘netstat -an | grep 2024’ for the default port. Is there a listening socket?

Next you could try to connect via SSH locally on the device, so that if any intermediate devices, such as a firewall, which might be blocking a connection could be avoided.

If you are still having problems, it might be helpful if you could attach your confd.conf file so we can check if everything is configured correctly.


#3

Hi Greg,

Thank for your response.I have not changed the default port used by SSH for the CLI that is 2024
I have started the confd and found that there is no listening socket on port 2024.

Please suggest.