ConfD User Community

Loading fxs files

I have compiled 3 fxs files for my project and copied to etc/confd/ where other fxs files are present

when i enter config mode, my generated objects dont show.

Entering configuration mode terminal
US-PF1VTZAD(config)# mo
------------------------^
syntax error: expecting
nacm - Access control

here i expect my data models to show up when i type mo. some one my team members are getting exactly that but not for me. i have checked the system setting and it’s exactly the same but i’m not getting the desired result. how to my generated data model to show up in the config mode?

All .fxs files that are on so called “load path” are loaded by ConfD and can be used from northbound interfaces (such as CLI). There are two places that affect load path:

  • confd.conf, namely the settings /confdConfig/loadPath/dir, see man confd.conf
  • the command-line option --addloadpath, see man confd.

I suppose that your colleagues have something different in one of these. You can verify what modules have been loaded by ConfD by looking into confd.log or by inspecting the output of confd --status.

If ConfD seems to have loaded all modules as expected, another possible explanation is that you do not have access to these modules, possibly because of incorrect nacm settings.

Thank you all your active support and help. the issue is finally resolved.

all the new managed objects from the new yang files started showing up after i ran “show configuration mo” and after that all the commands were returning proper information. not sure what difference this caused but now it’s all working fine.

Thank you once again to all those who helped me on this. this was a weird case and i wish i should have come to you all with some critical bug :slightly_smiling_face: