ConfD User Community

Module name prefix in front of responses


#1

Hi,

We have updated from confD 6.2 to confD 6.5 and now whenever we are calling an rpc the returned value is prefixed with the module name,

i.e.

{
moduleName : output{
“transaction-id”: “132ea561-a075-4dfc-8ec0-f4a2e2a28805”
}
}

Any idea how to remove this module name in front of it ? In 6.2 we didn’t have such an issue…and the our parsing scripts will need to be adapted in many places.

It was
{
output{
“transaction-id”: “132ea561-a075-4dfc-8ec0-f4a2e2a28805”
}
}

Thanx,

}


#2

Any input on this issue ?


#3

Which interface is this response coming from? Is this REST, RESTCONF using JSON, or JSON-RPC?


#4

Since RESTCONF didn’t exist in 6.2, I am assuming this is REST, but correct me if I am wrong.

I ran the action defined in examples.confd/rest/basic and used a JSON payload. I can see that there is a difference on “output”, that in 6.5 the module name is added. This may have been influenced when the support for RESTCONF was added. If you look at RFC 8040, section 3.6.2, you can see that the way it is done in 6.5 follows the RESTCONF standard. Most likely the REST interface was brought in line with RESTCONF.

If you would like to pursue this further, then you would need to open a ticket to see if it can be changed.


#5

We have updated our scripts so as to support this difference since we didn’t have any other option…
But at least it’s good to know that this is not configurable !!!
Thanx,