ConfD User Community

Netconf-console doesn't work, requiring paramiko for SSH


#1

Hi gents,
I’m playing with this tutorial https://github.com/janlindblad/bookzone/tree/master/1-intro in order to get familiar with YANG, NETCONF and so on.
Thence I’ve installed all the required tools but when I try to start netconf-console (I work on a Centos 7 VM spawned in VMWare workstation), even for a simple --hello request, I receive this output: “You must install the python ssh implementation paramiko in order to use ssh.”, despite having installed and updated it. I’ve installed netmiko too, same result.

Could someone kindly help me solve the problem?

Thanks in advance


#2

Hi,
As netconf-console is a Python script you can peak inside it and see that the import of paramiko failed.
Once you got your Python environment in order so that you can import paramiko, netconf-console should be good to go as well.
You can check if your python installation can import paramiko by doing something like this:

$ python
Python 2.7.6 (default, Sep  9 2014, 15:04:36) 
[GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.39)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import paramiko
>>>

#3

Hi cohult, thank for your support.
I’ve tried the solution you suggested but once I exit Python, the module is not actually imported. In the meanwhile I tried to find a workaround: i typed the ./bash_profile adding the string “export PYTHONPATH=/usr/bin/python3.6”, that is effectively the directory where paramiko is installed. Thence, sourcing bash_profile prior to work with the netconf-console, it seems to work correctly. The only (maybe) strangeness I can catch is that the XML response body (e.g. after a simple --hello) is not encompassed between the well-known <rpc-reply… > … , but rather <nc: hello xmlns…> … </nc:hello>. Is this behavior correct?

Thanks


#4

See the “-s” option, something like “netconf-console -s raw —hello”. “-h” will show you the available options.