ConfD User Community

Question about auto-complete on a container 'no' command


#1

Considering the following yang:

list my_list {
    key "idx";

    leaf idx {
        type string;
    }

    container my_container {
        tailf:cli-incomplete-no;

        leaf a {
            tailf:cli-boolean-no;
            type boolean;
            default true;
        }

        leaf b {
            tailf:cli-boolean-no;
            type boolean;
            default true;
        }

        leaf c {
            tailf:cli-boolean-no;
            type boolean;
            default true;
        }
    }
}

I would like to set the value ‘false’ to more than one leaf using a single ‘no’ command. When I check the
possible completions ConfD gives me the following:

localhost(config)# my_list 1
localhost(config-my_list-1)# no my_container a ?
Possible completions:

But even with the options not listed as possible completions I’m still able to run the command
and the result is as expected:

localhost(config-my_list-1)# no my_container a b c
localhost(config-my_list-1)# show full
my_list 1
no my_container a
no my_container b
no my_container c
!

Is this the correct behavior? I thought all leaves would appear as possible completions.

Thanks


#2

I can see same behavior. My guess is that this is bug. You should create ticket and notify your Tail-f support.