ConfD User Community

REST query returns "405 Method Not Allowed" error code in 6.3.0.2 version

I run the REST query for “show system monitor” for user defined role and gets the below error code in confd version 6.3.11.

HTTP/1.1 405 Method Not Allowed
Curl query: curl -v -X POST -u test:password http://10.26.144.33:80/rest/operational-state/show-system-monitor

But when we run the same command where in confd version 4.3.1 and it works fine.
Can you please suggest how to resolve this issue?

I’m afraid we can’t really help you. REST API was long deprecated and finally removed two years ago, confd-6.3 branch is over five years old and confd-4.3.1 … do you still keep its installation floppy discs?

Bad jokes aside, I am unable to run that old release, so I can only comment based on documentation and the somewhat scarce information you provide. It looks like show-system-monitor is a config false data node; if that’s the case, according to the documentation the right command line should look like

$ curl -v -X GET -u test:password \
http://10.26.144.33:80/api/operational/show-system-monitor

Note the GET method and different url path.

@mvf Do you have any further steps/pointers to resolve the REST issue.
We tried to enable confd debug, but didn’t get any debug logs…
Please let me know, how do we proceed further