ConfD User Community

--smp does't use muiltple cpu cores

HI

I was trying to utilize all my cpu cores for confd, according to the user guide. So the server is started with --smp 4 because my computer have 4 cores. What I expected is to utilize more than one cpu core to handle traffic. however I can only observer maximum “100%” of cpu, which means one cpu is used.

Do I need do something to really “enable” it.

================================================================================
2586827 ezhayog 20 0 2550324 265860 7956 S 100,3 3,4 2:32.30 confd.smp

Thanks

1 Like

Hi,

When ConfD is started the number of cores utilized is the number of cores that the CPU has. The ConfD 7.x --smp flag allows you to limit the number of cores to fewer than the maximum number of cores.
ConfD will balance the load when for example reading data over northbound interfaces, e.g. NETCONF, RESTCONF, CLI, etc.
For example, the ConfD CDB and DP API work cannot be handled by more than one core.
What type of work are you looking to balance across cores?

HI

Thanks, I am using a subscription CDB mechanism to dump the change. Otherwise, it is the EDIT config of around 10MB size file via netconf interface.

Brs
Charlie

Ok, The CDB API work will not be load balanced across cores.
A write transaction from a northbound interface, such as a NETCONF , will load balance the reading done as part of the transaction, but writing to the DB will not be load balanced across multiple cores either