ConfD User Community

suppressRangeKeyword not working as expected


#1

Hi Team,

I want to hide keyword range on CLI . I tried setting true in confd.conf.full and at other location also where it is used but still I can see on CLI keyword “range”

ubuntu-xenial(config)# A B ?
Possible completions:
<tag:unsignedInt, 1 … 500> range
ubuntu-xenial(config)# A B range ?
Possible completions:
<tag, 1 … 500>
I don’t want range keyword to be seen while configuration . How it can be handled?


#2

confd.conf.full may not be the right location - you need to modify the .conf file that is used by confd when it is starting, usually given by -c or --conf (if you do not use one of these options, I suggest you do to have better control over what file is being used).