ConfD User Community

Yang-version and advertised capabilities

Hi. I am using confd basic and two different netconf clients. I am following the documentation to define a new module. The new module capability is advertised in the clients.
However, if I am using yang-version “1.1” in the yang file, the module is no longer advertised (although it is shown as loaded in confd --status).
Is there any limitation of the basic version? Or any setting that I might have overlooked?
Thanks.
Alex M

Hi, the mechanism for advertising YANG modules is different with YANG 1.1 modules (done through the yang-library). See https://tools.ietf.org/html/rfc7950#section-5.6.4